RussianLDP Рейтинг@Mail.ru
WebMoney: 
WMZ Z294115950220 
WMR R409981405661 
WME E134003968233 
YandexMoney: 
41001198119846 
E-gold:
5128052

Beyond Linux From Scratch. Версия 6.0

Глава 31. Дополнительные пакеты GNOME

AT SPI-1.6.0

Введение в AT SPI

Пакет AT SPI содержит Assistive Technology Service Provider Interface. Он полезен для переадресаци событий интерфейса пользователя к доступным приложениям и адаптивным/вспомогательным технологиям.

Информация о пакете

Зависимости AT SPI

Требуемые

GAIL-1.8.0 и libbonobo-2.8.0.

Опционально

GTK-Doc-1.2.

Установка AT SPI

Установим AT SPI запуском следующих команд:


./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
            --libexecdir=`pkg-config --variable=prefix ORBit-2.0`/sbin \
            --disable-gtk-doc &&
make &&
make install

Описание команд

--libexecdir=`pkg-config --variable=prefix ORBit-2.0`/sbin: Эта опция помещает файлы libexec в $GNOME_PREFIX/sbin вместо $GNOME_PREFIX/libexec.

--disable-gtk-doc: Эта опция предотвращает пересборку документации при выполнении команды make.

Содержание

Пакет AT SPI содержит библиотеки libspi, libcspi и libloginhelper, модуль GTK+ libatk-bridge.so, модули ORBit-2.0 Accessibility и at-spi-registryd.

Описание

at-spi-registryd

at-spi-registryd является демоном регистрации, который разрешает связь между интерфейсом пользователя и вспомогательными устройствами.

Последнее обновление 2004-11-29 12:04:53 -0700.

Поиск

 

Найди своих коллег!